EWC DASH automated updates have been suspended
Incident Report for TrendzAct CRM
Resolved
This incident has been resolved.
Posted Apr 15, 2020 - 07:30 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 14, 2020 - 12:44 MDT
This incident affected: API and External Access (EWC-DASH integration).