Unable to save Tickets / Engagement Tab takes long time to load
Incident Report for TrendzAct CRM
Resolved
This incident has been resolved.
Posted Apr 27, 2020 - 10:51 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 27, 2020 - 10:17 MDT
Update
We are continuing to investigate this issue.
Posted Apr 27, 2020 - 09:47 MDT
Investigating
We are currently investigating this issue.
Posted Apr 27, 2020 - 09:47 MDT
This incident affected: Site Performance and Tickets.