TrendzAct Down
Incident Report for TrendzAct CRM
Resolved
All services have returned healthy. This incident has been resolved.
Posted Jan 08, 2020 - 10:16 MST
Update
Working to restore access to the CRM now. ETA is less than 10 mins but will keep you posted.
Posted Jan 08, 2020 - 10:06 MST
Identified
Mitigation steps are currently being applied.
Posted Jan 08, 2020 - 09:56 MST
Investigating
CRM website is down, we are performing a deep investigation to resolve this as soon as possible.
Posted Jan 08, 2020 - 09:54 MST
This incident affected: Site Performance, User Access, Contacts, Tickets, Dashboard, Reporting, and File Storage.