Unable to save Tickets / Engagement Tab takes long time to load
Incident Report for TrendzAct CRM
Resolved
This incident has been resolved.
Posted Apr 24, 2020 - 11:45 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 24, 2020 - 11:20 MDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 24, 2020 - 11:09 MDT
Update
We are continuing to investigate this issue.
Posted Apr 24, 2020 - 10:57 MDT
Investigating
We are currently investigating this issue.
Posted Apr 24, 2020 - 10:23 MDT
This incident affected: Site Performance, User Access, Contacts, Tickets, Dashboard, Reporting, and File Storage.